The latest stable version of Process Hacker is 2.35 (r5898).

System requirements:

  • Windows XP (SP2)/Vista/7/8, 32-bit or 64-bit.
  • Intel Itanium platforms are not supported.

If you like this software, please Donate to show your support!